Installing the Java Runtime Environment

The following client tools require the 64-bit version of Java 8 (also known as Java 1.8):
  • ybbackup
  • ybbackup-list
  • ybload
  • ybrestore
  • ybunload

Java 9 and 10 are not supported. Only the JRE (Java Runtime Environment) is required, but you can install the complete JDK if you prefer. The JRE is required on both Linux and Windows platforms.

Follow these steps to check that the correct version of Java is installed and install it or upgrade it if necessary. (You can install the client tools if Java is not found, or if the wrong Java version is found, but you cannot run them.)

  1. Check the Java version on your client system by using the java -version command. For example, on an Ubuntu Linux client:
    me@yb.io:~$ java -version
    java version "1.8.0_101"
    Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

    The build numbers may vary; what you are looking for is 1.8 in the version string and a reference to 64-Bit. In this example, the correct version of Java is already installed. You would be able to proceed with the client tools installation.

  2. If your client system does not have the JRE installed (or has the wrong version), go to the Java SE site and download Java 8.
    Note: For Windows clients, a Windows Offline (64-bit) installation is recommended.
  3. Follow the Oracle installation instructions for your client platform.
  4. Check the Java version again when the installation is complete.